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Using this Quick Start Guide 

This guide will lead you through the simple steps of creating math illustrations and 

bringing them into another application, such as Word or PowerPoint. 

For a complete reference, refer to the Math Illustrations Manual and the built-in Help 

system. 

This material is based upon work supported by the National Science Foundation under 

Grant No. 0750028 
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Getting Oriented 

Math Illustrations lets you quickly create illustrations using familiar drawing tools and a 

natural constraint-based system. You can easily bring these illustrations into your 

worksheets, tests, and presentations. 

 

To create an illustration: 

 Draw with the tools in the Draw tool panel.  
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You can press ESC to stop drawing with a tool. 

 Once you’ve created the elements for your drawing, use the tools from the 

Constrain and Construct tool panels to specify their relationships. For example, 

you can set the length of a line segment or make two lines perpendicular.  

     

Note that only the tools relevant to the current selection are available. So, if you’ve 

selected a line, you’ll have the option to set the line length but no option to set the 

angle, since this isn’t a relevant constraint for a single line. 

 Finally, label your illustration with tools from the Annotate tool panel. 

Annotations display like a constraint, but won’t actually change any element in 

your drawing. 

 

Understanding Constraints and Annotations 

After you’ve set a few constraints, Math Illustrations can figure out the remaining 

constraints from the ones you’ve previously set. When the drawing is fully constrained, if 

you try to set an additional constraint, Math Illustrations will ask you if you want to 

create an annotation, or just discard the constraint. 

Don’t worry if this seems a little confusing at first. Once you’ve created a few drawings, 

it will come naturally. 
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Creating drawings 

We’re going to show you two different ways to create a math illustration. In the first 

example, we’ll draw a figure and annotate all of the relationships to make a quick but 

inexact illustration. In the second example, we’ll use a mixture of constraints and 

annotations to create an accurate drawing. 

You can choose whichever method best suits your needs. 

Creating a quick drawing 

You can use Math Illustrations as a “math smart” drawing tool to quickly sketch out 

illustrations. In this section, you’ll quickly sketch a triangle and add annotations, without 

worrying about whether the drawing is to scale. 

Example of creating a sketch of a triangle: 
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 Choose the Line Segment tool  and draw a triangle.  

Note that you can draw a perpendicular or horizontal line by holding down the 

Shift key as you’re dragging.  

To create connected elements, move the cursor over an existing element until its 

highlight appears, indicating the start, end or center where the new element will 

“snap.”  
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 Label each line as indicated in the illustration by choosing the Selection tool , 

clicking on a line, then clicking on the Annotate Distance/Length tool  and 

entering a label. 

If you make a mistake, you can use the Undo and Redo options on the Edit menu. 

Notice that the rough drawing above is not to scale and annotations have no effect 

on the geometry. You can drag any point or line to see that the triangle does not 

maintain its shape. In the next section, we’ll show you how to create accurate 

drawings that maintain their shape. 

Creating an accurate drawing 

Math Illustrations can help you create accurate drawings by using constraints and 

constructs to specify relationships such as lengths and angles. In this section, you’ll 

create an accurate drawing of a triangle using a mixture of constraints and annotations. 

Example of creating an accurate drawing of a triangle: 
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 Choose the Line Segment tool  and draw a triangle, following the tips in the 

preceding section. 

 Make line segment AB and BC perpendicular by choosing the Selection tool , 

clicking to select line segment AB, and then holding down the Shift key and 
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selecting line segment BC. Then, choose the Constrain Perpendicular tool  

to make these two line segments perpendicular. Notice the perpendicular symbol 

that appears on your drawing. 

You can test this constraint by dragging your drawing and noting that the two line 

segments remain perpendicular. 

 Set the length of line segments AB and BC as indicated in the illustration by 

selecting each line, choosing the Constrain Distance/Length tool , and 

entering a length. Notice that when you set the second length, Math Illustrations 

scales it in proportion to the first length. 

 Set the length of line segment AC by choosing the Constrain Distance/Length 

tool  and entering “x” as the length. 

The following dialog box appears: 

 

When you specify a constraint that Math Illustrations can calculate from the 

information you’ve already provided, you’re given the choice to discard the 

constraint or to change it to an annotation. 

 Change this constraint to an annotation by selecting “Create an annotation from 

the distance” and clicking OK. 

Notice that this triangle retains the length and perpendicular constraints. If you try 

to drag the triangle, it will maintain its shape and proportions. 
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Controlling the Appearance of Your Illustration 

In this section, we’ll show you how to change the appearance of a particular element, and 

also how to set your preferences so that any element you create will have the appearance 

you want. 

To change the appearance of a particular element: 

 Choose the Selection Tool  and select the element. 

 Right-click and select All Properties from the context menu. 

 Choose the property you want to change and provide the new setting. 

To change the default appearance of element types: 

 Choose Preferences from the Edit menu. 

 Select the element you want to change and make the desired changes. 

 Click OK to accept the change. 

Changing the appearance of a particular element 

We’ll step you through the process of fine-tuning the triangle illustration you made 

previously.  

Example of changing line color, constraint color, and point size: 
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 Use the accurate triangle drawing you created previously, or recreate it. 

 Choose the Selection tool , hold down the Shift key, and select all three line 

segments. 

 Right-click anyplace and choose Line Properties from the context menu 

 

 Click Line Color and select the red box. 

All of the lines turn red. 

 Hold down the Shift key and select the two constraint lines. 

 Right-click choose Line Properties from the context menu and proceed as in the 

steps above. 

 Click Text Properties, Text Color, and select the black box. 
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All of the constraints turn black. 

 Hold down the Shift key and select all three of the points (vertices) of the triangle. 

 Right-click and choose Point Properties from the context menu. 

 

The points shrink in size. 
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Changing the default appearance of elements 

In the previous section, we showed you how to change a specific element. If you want an 

element to look a certain way whenever you draw it, you can set your preferences to 

control the default appearance of an element.  Changing a default setting will not change 

the properties of elements already drawn. 

We’ll set the appearance changes you just made as the default settings. 

Example of changing the default settings: 

1. Choose Preferences from the Edit menu.  Note the page tabs on the left side 

panel. 

 

2. Click Geometry; in the Point window set the Point Size to 1; in the Line window 

set the Line Color to red. 

3. Click Math; in the Constraint window set the Line Color and Font Color to 

black. 
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4. Click OK to close the Preferences dialog. 

Notice that when you draw now, the objects you create have the style you just 

specified. 

Making other changes to your illustration display 

You can change the size of your illustration by scaling it up or down. Note that scaling 

only changes the math elements and does not change the size of the text. 

You can also hide or show various elements in your illustration 

To scale your illustration up or down: 

 Click the Scale Up icon  to increase the size of your illustration, or 

click the Scale Down icon  to decrease the size of your illustration. 

Note that you can use a combination of changing the zoom and changing 

the scale to quickly change the text size. For example to enlarge the text, 

press CTRL and = or CTRL and  to zoom in, and then press  or 

ALT and – to scale down everything but the text. 

To hide or show elements in your drawing: 

 Choose the Selection tool  and select an element. 

 Right-click the element and choose Hide from the context menu.  

 Right-click over a blank area in the drawing window and choose Show All to 

show all hidden elements. 

To redisplay individual hidden elements or hide others: 

 Select Toggle Hidden from the View or Context menu. 

 Faintly displayed elements are hidden.  Click any drawing element with the magic 

wand  to change it’s display status from hidden to displayed or visa versa. 
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 Click the Selection tool  when you are finished. 

In the following example, we’ll show you how to hide the point labels using the first 

method. 

Example hiding elements: 
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 Using the triangle from the previous example, choose the Selection tool , hold 

down Shift, and select all of the point labels (A, B and C). 

 Right-click and select Hide from the context menu. 
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Changing your display 

You can customize your display to meet your needs. 

Showing the page boundary, grid, and axes 

If you’re bringing your finished illustrations into another application, such as a Word 

document, turning on page boundaries is an easy way to keep track of the size of your 

illustration. 

You may also want to display the grid to align objects, or turn on the axes display. 

To hide or show the page boundary: 

 Choose Page Boundaries from the View menu to toggle the page 

boundary display.  A checkmark by the menu item indicates the 

boundaries are displayed (on).   Click it again to turn it off. 

To hide or show the grid: 

 Choose Grid from the View menu to toggle the grid display.  A 

checkmark by the menu item indicates the grid is displayed (on).  Click it 

again to turn it off. 

To hide or show the axes: 

 Choose Axes from the View menu to toggle the axes display.  A 

checkmark by the menu item indicates the axes are displayed (on).  Click 

it again to turn it off. 

 Alternatively you can use the icon  .  Click it until you get the 

desired configuration. 

Displaying tool panels and setting the zoom 

You can set up your tool panels to make frequently-used tools easy to reach, or to hide 

infrequently-used tools. 

You can also quickly zoom in and out of your illustration. 
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To set up your tool panels: 

 Drag your panels to any position on the screen. To drop them back into 

position, drag them until you see the blue highlighted square, and then 

release the mouse to let them snap back into place. 

 Hide a panel by clicking the close button on the panel, or show a hidden 

panel by choosing Tool Panels from the View menu and then selecting 

the tool panel to show.  Checked tool panels are displayed.  Click a 

checked panel to hide it. 

 Return all tool panels to their default location by choosing Tool Panel 

Configuration from the View menu and then choosing Default. 

To zoom in or out of your illustration: 

 Choose the desired zooming or scaling option from the View menu or one 

of the scaling / zooming icons on the icon bar. 

Distinguishing between constraints and annotations 

You may want to easily see which elements in your illustration are bound by constraints, 

and which ones are simply annotated. 

To display annotated and constrained elements: 

 Click on the Distinguish Constraints/Annotations icon  to toggle 

the display of annotations and constraints. Annotations are indicated with 

an “A” while constraints are indicated with a padlock. 
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Bringing your Illustration into Word or PowerPoint 

There are two methods of bringing a drawing into another application: Exporting the file 

to a compatible format and inserting the file into the other application, or copying and 

pasting the illustration. 

Exporting your illustration 

You can export your illustration into a bitmap format (such as PNG or JPEG) or into a 

vector format (EMF). EMF files tend to have a cleaner appearance, but not all 

applications can read them. 

To export and import into Word using the EMF format: 

 Choose Export from the File menu, and then choose Windows Enhanced 

Metafile (emf). 

 Specify a file name and save the file. 

 Go into Word and insert the picture from a file. 

Copying and pasting your drawing 

You can copy and paste everything in the drawing window, or copy and paste a specified 

area of the illustration. Generally, copying the specified area will better maintain the 

scale of the illustration. 

To copy and paste a specified area of your illustration into Word: 

 Choose the icon  or Copy Region from the Edit menu. 

 Position the corner of the selection square at the edge of the area you want to copy. 

 Click and drag the rectangle outline over the area you want to copy. 

 When you release the mouse button, the area is copied to the clipboard. 

 From Word, paste into your document. 
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More example illustrations 

In this section, we’ll step you through creating several more sample illustrations. 

There is also a huge collection of examples in the Figure Galley found in the File menu. 

Creating a circle and its diameter: 

A

B

C D

 

1. Choose the Circle tool  and create a circle. 

2. Choose the Line Segment tool  and create a line that connects to both sides of 

the circle. 

3. Choose the Selection tool  and hold down the Shift key to select both the line 

segment and the center of the circle (point A). 

4. Choose the Constrain Incident tool  to place the center of the circle on the 

line segment, creating a diameter line. 
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Creating an incircle of a triangle: 

 

1. Choose the Line Segment tool  and draw a triangle. 

2. Choose the Circle tool  and create a circle inside the triangle. 

3. Choose the Selection tool  and select the circle, then hold down the Shift key 

and select one side of the triangle. 

4. Choose the Constrain Tangent tool  

 The circle becomes tangent to the selected side. 

5. Repeat steps 3 & 4 with the other two sides of the triangle. 
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Creating a “3D” illustration: 

 

You can use translation to create an object that appears to be in three dimensions. 

 Create a triangle using the Line Segment tool . 

 Select all three line segments with the Selection tool . 

 Choose the Construct Translation tool . 

 Draw a translation vector running north to south. 

Math Illustrations creates a second triangle. You can drag the endpoints of the 

translation vector to modify the position of this second triangle. 

 Using the Line Segment tool , create the connecting lines between the two 

triangles. 

 Select the three “inside” lines, right-click on one, and choose All Properties from 

the context menu. 

 Change the Line Style to a dotted line and choose OK. 

 Select and Hide all of the extraneous elements, including the translation line, 

points, and point labels. 
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 Select a pair of the dotted “inside” lines and click Perpendicular  from the 

Annotate toolbox.  Repeat for the other pairs. 

Creating a line with a specified slope and coordinates: 
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 Click the Axes icon  or choose Axes from the View menu to display the axes. 

 Choose the Infinite Line tool  and create a line. 

 Choose the Point tool  and create a point on the line. 

 Choose the Selection tool  and select the point. 

 Choose the Constrain Coordinate tool  and enter the coordinates (3,7). 

 Choose the Constrain Slope tool  and enter a slope of 1. 

 Select the slope, right-click and choose Hide from the context menu. 
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Graphing functions: 
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 Click the Axes icon  or choose Axes from the View menu to display the axes. 

 Choose the Function tool  from the Draw toolbox.   

 In the Y=  data entry line, type: X^2*(a+b) and press OK. 

 Math Illustrations creates a parabola. 

 Choose the Function tool  from the Draw toolbox.  In the Y=  data entry line, 

type: sin(x) and press OK. 

Math Illustrations creates a sine wave. 

 


